Denwer 3 pre 4. Update to php 5.4, php 5.6, apache 2.2.31, 2.4

10 Мар

Здесь размещу уже всем давно известного старика Денвера (оригинал) Denwer3_Base_2013-06-02_a2.2.22_p5.3.13_m5.5.25_pma3.5.1_xdebug.exe

и мои апдейты для него.

PHP 5.4.45

Denwer3_Update_2016-03-10_p5.4.45_xdebug.exe
Архив содержит:
PHP 5.4.45 (VC9) TS
ioncube_loader_win_5.4.dll
php_xdebug-2.4.0rc4-5.4-vc9.dll

Для того чтобы добавить в ваш Денвер это обновление, необходимо скачать необходимый вам архив и заменить из него все что находится в папке /usr/local/php5, или предварительно переименовать/удалить старую папку php5 и создать новую с таким же названием.

Как установить Imagick (ImageMagick) расширение на Денвер? (оригинал статьи)
Все проделывать с выключенным денвером!
Скачайте например версию 3.4.1 по следующей ссылке http://pecl.php.net/package/imagick/3.4.1/windows для PHP 5.4 необходимо выбрать версию «5.4 Thread Safe (TS) x86»
Далее, из скаченного архива файл php_imagick.dll закинуть в папку /usr/local/php5/ext, а файлы с именами CORE_RL_*.dll скопировать в папку bin с апачем — /usr/local/apache/bin.

Добавить в php.ini
[Imagick]
extension=php_imagick.dll

Все готово, расширение установлено!

Denwer3_Update_2016-03-10_a2.2.31_p5.4.45_xdebug.exe
Архив содержит:
Apache/2.2.31 (Win32) (VC9)
PHP 5.4.45 (VC9) TS
ioncube_loader_win_5.4.dll
php_xdebug-2.4.0rc4-5.4-vc9.dll

Для того чтобы добавить в ваш Денвер это обновление, необходимо скачать необходимый вам архив и заменить из него все что находится в папках /usr/local/php5 и /usr/local/apache, или предварительно переименовать/удалить старые папки php5 и apache и создать новые с такими же названиями.

PHP 5.6.19

Denwer3_Update_2016-03-10_a2.4.18_p5.6.19_xdebug.exe
Архив содержит:
Apache/2.4.18 (Win32) (VC11)
PHP 5.6.19 (VC11) TS
ioncube_loader_win_5.6.dll
php_xdebug-2.4.0rc4-5.6-vc11.dll

Для того чтобы добавить в ваш Денвер это обновление, необходимо скачать необходимый вам архив и заменить из него все что находится в папках /usr/local/php5 и /usr/local/apache, или предварительно переименовать/удалить старые папки php5 и apache и создать новые с такими же названиями.

24 thoughts on “Denwer 3 pre 4. Update to php 5.4, php 5.6, apache 2.2.31, 2.4

  1. Спасибо, помогли с пакетом php, а то на официальном сайте эту версию уже не скачать

  2. А и спасибо. При верстке сайта поставил один плагин новый а он требует версию рнр выше чем в старом денвере. Полез искать и сразу наткнулся на вас. Все стоит под win 7х64 и без проблем обновилось и работает.

  3. Странно читать вышеизложенные комментарии. Как оно заработало, если требует файл msvcr110.dll, которого нет в пакете.

    Но и после добавления этого файла, localhost не стартует.

  4. Благодарю Вас, обновления Denwer3_Update_2016-03-10_a2.2.31_p5.4.45_xdebug.exe и Denwer3_Update_2016-03-10_a2.4.18_p5.6.19_xdebug.exe на windows 7 работают корректно, проблем нет. Благодарю за выложенные решения.

  5. Спасибо, установил обновление Denwer3_Update_2016-03-10_a2.4.18_p5.6.19_xdebug.exe на виндоус 7 . Отлично ! Теперь php 5.6 на денвере это то, что надо. Еще раз спасибо за вашу работу!

  6. Спасибо!!! Установила обновление Denwer3_Update_2016-03-10_p5.4.45_xdebug.exe. Работает))) Все быстро и очень просто.

  7. «Denwer3_Update_2016-03-10_a2.4.18_p5.6.19_xdebug.exe»
    Не удается получить доступ к сайту
    (((

  8. Спасибо! С начало хотел установить Denwer3_Update_2016-03-10_a2.4.18_p5.6.19_xdebug.exe, не получилось. Получилось с Denwer3_Update_2016-03-10_p5.4.45_xdebug.exe.

  9. Спасибо огромное! Действительно на XP пакет Denwer3_Update_2016-03-10_a2.4.18_p5.6.19_xdebug.exe не встал. А вот Denwer3_Update_2016-03-10_a2.2.31_p5.4.45_xdebug.exe встал и работает.
    Будьте счастливы!

  10. У меня проблема распаковал Denwer3_Update_2016-03-10_a2.4.18_p5.6.19_xdebug.exe | Denwer3_Update_2016-03-10_p5.4.45_xdebug.exe распаковал все правильно, но выходит одна ошибка exif_read_data не включается помогите плз.

  11. Большое спасибо. Очень выручили. А страницу Вашу обязательно в закладки.

  12. Еще раз большое спасибо. Хочу попросить Вас добавить в эту статью или же новую о том, как на Denwer установить php 7, ибо сейчас это очень актуально.
    Спасибо

  13. Обновил Денвер архивом Denwer3_Update_2016-03-10_a2.4.18_p5.6.19_xdebug.exe Денвер стартует но при попытке войти в панель localhost/tools/phpmyadmin/ выдает ошибку. Где копать? Что не так.

  14. Спасибо, запустился! В отличие от версии php5 с официального сайта. Не пришлось разбираться

  15. Спасибо за выложенное обновление, но хочу добавить по поводу xdebug в версии 5.6. Не работает пока не изменишь php.ini следующим образом:
    ;отредактировать или добавить строчку, если нет
    extension_dir = «ext»
    ;убрать путь в местах подключения библиотек иначе библиотеки не грузятся, а в лог ;падают две ошибки. Теперь загрузчик просто будет их искать в папке ext
    [Zend]
    zend_extension=»ioncube_loader_win_5.6.dll»
    [xdebug]
    zend_extension=»php_xdebug-2.4.0rc4-5.6-vc11.dll»
    ;включить эти параметры:
    xdebug.profiler_enable = 1
    xdebug.profiler_enable_trigger = 0
    xdebug.profiler_output_dir=»/tmp»
    xdebug.profiler_output_name = «cachegrind.out.%u»
    xdebug.remote_enable = 1
    xdebug.remote_handler = «dbgp»
    xdebug.remote_host = «localhost»
    xdebug.remote_log = «/xdebug.log»
    xdebug.remote_port = 9000

  16. Автору огромное спасибо!
    Но если есть ещё динозавры, типа меня, у кого Windows XP, имейте в виду, что версия PHP 5.6 на ней не заводится. И п5.5, кстати, тоже. Во всяком случае, у меня не получилось.
    Провозился несколько часов, скачал несколько готовых пакетов обновления где нужно только заменить папку php5 и в некоторых вариантах apache с разных сайтов, но всё время вылетали разные ошибки. В итоге решил попробовать 5.4 (на тот момент был уже на другом сайте) и, о чудо! всё заработало сразу же!
    Правда, была одна ошибка при старте и остановке, но Денвер при этом работал. Ошибка вылечилась скачиванием файла php_xdebug-2.2.3-5.4-vc9 (напомню, это для php 5.4) оттуда https://xdebug.org/download… и заменой на него строчки в php.ini

  17. Как и у нескольких отписавшихся, у меня тоже Denwer3_Update_2016-03-10_a2.4.18_p5.6.19_xdebug.exe не заработал. При запуске была ошибка «Запуск программы невозможен, так как на компьютере отсутствует MSVCR110.dll»
    Попробовал поставить Denwer3_Update_2016-03-10_a2.2.31_p5.4.45_xdebug.exe и Denwer запустился без ошибок! Спасибо автору за готовое и рабочее решение! Да ещё и с ioncube на борту.
    Для статистики, Windows 7, 64 bit

    PS: Когда пролистал страницу чтобы поблагодарить автора, заметил коммент Сергея от 05.11.2017 at 10:17. Теперь, когда всё уже работает, пробовать не хочется, но сообщение скопировал и при случае попробую с такими настройками. Спасибо и тебе, Сергей.

  18. Спасибо автору статьи и файлов!
    Пробовал ставить Denwer3_Update_2016-03-10_a2.2.31_p5.4.45_xdebug.exe на свежеустановленную Windows XP но при запуске вылетает ошибка, а если кликнуть по значку с пером в трее, открывается окно с ошибкой, где тест в какой-то непонятной кодировке. На форуме Денвера нашёл упоминание о подобной ошибке. Там же и было решение — нужно установить вот этот компонент:
    Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package MFC Security Update
    http://www.microsoft.com/ru-ru/download/details.aspx?id=26368
    Установил и Денвер больше не ругается :)

    Чуть позже заметил, что значок в трее вместо пера стал просто белым прямоугольником… Но на работу Денвера это не влияет.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.